HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

500 Internal Server Error


#1

I’ve uploaded the helpspot.zip file to my hosted webserver, decompressed and set up the ‘config.php’ file.

However, when I go to ‘installer.php’ in my browser I get:

"Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@cleverfilemaker.co.uk and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request."

I don’t know enough about it to troubleshoot, can you help?

Thanks


#2

Someone needs to look at the web server’s error log, like the message implies. If you have access to it, see if you can find the error. There’s also another problem with your error pages, but that’s a different problem. Good luck.


#3

Hi Matt,

Make sure an error wasn’t introduced in config.php like an invalid bit of syntax. If you have a link to at phpinfo dump that would be useful so we can see what your PHP setup is.


#4

Hi John and Ian, and thank you for your replies.

An email to the hosting company ascertained that the permissions on the files were wrong, hence the installer was being prevented from running. This was my mistake entirely, as I had uploaded the files using a ‘root’ password, so all the files were set to permissions of ‘777’.

It’s now been sorted. Thanks for your help.


#5

Ah, great. Love an easy fix!


#6

So, what do the permissions need to be set at. I extracted the files server end with the understanding it should keep the file permissions as zipped…


#7

My hosting company told me that they should be 644 for files and 755 for folders. After I’d (rather laboriously) changed all these it all worked ok.