HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

Access Vioation after Upgrade to 1.5


#1

I just downloaded and followed the instructions for the 1.5 upgrade. I got an upgrade successful from installer.php, but when I go to admin.php, I get this error:

PHP has encountered an Access Violation at 01028E5E

Any ideas?
Thanks.


#2

Hi Jeff,

Can you tell me about your setup, OS, PHP version, PHP as CGI?

We have a few other customers with this issue but it seems to be random. It’s never happened in any testing and we can’t replicate it here.

Ian


#3

I am running:
Windows XP SP2 fully patched
IIS 5
PHP 5.1.5
Not sure what PHP as CGI means


#4

Thanks Jeff. PHP can be installed in ISAPI mode or CGI mode. It’s no problem if you’re not sure which it is. Are you running HelpSpot on a server or it’s on a desktop right now?


#5

Oh, yeah. It’s running in ISAPI mode and it’s on a desktop.


#6

I put that file in place, restarted IIS, not the entire computer, and still get the same error:

PHP has encountered an Access Violation at 01028E5E


#7

Thanks Jeff. I think we’re on to the solution. It’s being worked on now and I’ll be sending out an email when it’s available. If I need any other information on the issue from you I’ll send over an email. Thanks for your patience with this.


#8

Not a problem. Thank you.


#9

I installed the update. Now, I can log in, but when I click on anything, it takes me back to the login screen. If I log in again, I’m taken to the item that I clicked on. If I click on Admin, then re-login, I’m taken to the Admin screen, but the graphs do not show. They just have the red “X” placeholders.


#10

Just installed the patched admin.php and get the same result.


#11

Can you check that there’s a table in your database for HS_Sessions or HS_Sessions2


#12

I have HS_Sessions. I’m not logged into the program, but I do have an entry in the table. Should I not have?


#13

I just realized you are actually on a slightly older patch. Try the newest which should delete the HS_Sessions table and create a HS_Sessions2 table which is correct. You’ll need to overwrite the files and run the installer. I’ll send the link in email.


#14

I downloaded the latest version, installed the patched admin.php and re-ran the installer. Everything appears to be working properly now.

Thank you so much for your help. I’ll let you know if I see any other issues.

Thanks again.


#15

Yeeeaaaaaaaaaaahhhhhhhhh!!!

Ok it’s been a bit of a rough day :slight_smile:

Please do let me know if you hit anything else.