HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

AD Lookup


#1

I am trying to setup the AD lookup feature. I know the file is connecting to the ldap server fine, but I think the problem is in the $dn line. I don’t understand the variables that need to be defined.

$dn = “OU=People,OU=staff,DN=your,DN=adserver,DN=com”;

I’m not sure if this is a problem, but my users are not in a user-specific OU in AD. They are just under the normal users folder in AD. Do I need to make a new OU and drag all of my users in there?

Also, I’m confused about the syntax for defining the DN. If the full server name is mhbd.mhpc.com, would it be $dn DN=mhbd,DN=mhpc,DN=com?

Please advise. Thanks!


#2

Hi Nick,

Any luck with this? I haven’t heard of anyone needing to create new domains to use this feature, but like I’ve said AD isn’t an area I have a lot of experience in.


#3

No luck yet. I’m still stuck. I continue to receive the ldap search failed error on the php file, and whenever I integrate the file into helpspot I just receive this message in the error log in helpspot:
XML Parser Empty document ajax_gateway.php 353

I know that it has to be connecting to my AD, I just can’t figure out where it is getting hung up in terms of searching.

Any help would be greatly appreciated!!!


#4

Still no luck…I still receive the ldap search failed on the php page and recieve that an error is occured when i try the live lookup. Even though I have the AD Integration working, could there be some other module or something I am missing in the php/apache install?


#5

Since you have Black Box auth working with AD the right libraries must be installed in PHP. Try accessing the script directly and see what’s returned. For example try going to your Live Lookup script like this in your browser:

http://mydomain.com/livelookup.php?last_name=smith

Use a last name that should be found and see if you get XML back. If you do then at least you know that part is working.

Also in HS make sure in Admin->Settings->Live Lookup you have it set to HTTP - GET since that’s what the sample script expects.


#6

Still no luck.

Here is the returned error just as I have been receiving:

XML Parsing Error: syntax error
Location: http://a2-6139/helpspot/custom_code/lookup.php?last_name=george
Line Number 1, Column 1:ldap search failed
^


#7

I’m really stumped. As far as I’m concerned, it looks like I have the configuration correct. I’m concerned about the permissions in the AD environment. For people that have this working, what environments have you had it work on? Did it require any additional changes in AD to get it to work?