HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

Automation, again


#1

I’ve seen something similar to this but I’m not sure if it’s the same problem.

As part of an ongoing attempt for quality, I’ve created an automation rule that sends a nagging e-mail to the assign users for each issue that is active and that has had not public activity for 24 hours.

The rule works perfectly. However, as the action of the rule updates the issue, the assigned user actually gets two e-mails for the same thing. The first from the rule and the second as a notification of the update to the issue.

Is it possible to mark an automation rule such that it does not update the user when it updates the call?


#2

Hi Jamie,

Not currently, but the next release has an option to suppress notifications generated by the auto rule being executed. That option should fix this for you.


#3

I am having what I think is a similar problem

Since helpspot wasn’t automatically emailing the Assigned Staffer whenever a customer would update an existing request (via the web portal or via email), I created an automation rule stating with the following (ANDed):

Open/Closed: Open
Minutes since last customer update: Less than 5 (note, my tasksphp and tasks2.php areboth called by the VBScript every 5 minutes)

The automation rule sends an email alert to the assigned staffer. Problem is, it sends 2 - one according the template I place in the automation rule, another just to notify the staffer than an automation rule has been triggered. How can I suppress this second email? Or is there a better way to get Helpspot to email the assigned staffer when a user updates a request?


#4

Hi Sam,

In the next release automation rules have an option to suppress the notifications the rule creates by being run (not the ones you specify in actions) which should fix this for you.

Now, there is a better way to be updated. In fact, it should be happening. If you’re the assigned user you receive a notification when the customer updates. The only way you wouldn’t is if you turned off email notifications in “preferences”.

If you’re not the actual assigned user though then an automation rule would be the way to get notifications for requests which are not yours.


#5

Hi Sam,

I’m not entirely sure how you have things setup. Since your email is working it’s like a configuration issue. If you want to send your login info to customer.service at userscape.com I can take a look as see what’s going on.