HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

Can't Install - MSSQL Database Connectivity


#1

Hello,

I’m having trouble getting HelpSpot installed. installer.php shows:

Can connect to database: Yes
PHP version 4.3.9 or higher: Yes
PHP IMAP extension installed: Yes
PHP XML extension installed: Yes
PHP GD extension installed: Yes
PHP.ini upload_tmp_dir check: Yes
PHP ZLIB extension installed: Yes
PHP MBSTRING extension installed: Yes
PHP TIDY extension installed: Yes

But when I click Finish, it reports:
Cannot access database. If this is a new installation please go to the installer page.

I’m using IIS & MSSQL. I used the HelpSpot Windows installer.

In php.ini, I have extension=php_mssql.dll. In the php directory I have ntwdblib.dll, version 2000.80.194.0. In config.php: the helpspot SQL user exists, the login is correct, the DB name is correct, and the user is the helpspot DB owner. Mixed mode authentication is enabled on the server.

define(‘cDBTYPE’,‘mssql’);
define(‘cDBHOSTNAME’,‘localhost,1433’);
define(‘cDBUSERNAME’,‘helpspot_user’);
define(‘cDBPASSWORD’,’’);
define(‘cDBNAME’,‘helpspot_db’);
define(‘cHOST’,‘http://webserver.domainname.org:8080/helpdesk’);

The PHP extension in IIS is configured to use the copy in C:\Program Files\helpspot\php.

Thanks,
David


#2

Hi David,

Did you use the Windows Installer or you manually installed the components?


#3

Hi Ian,

As mentioned in my post I used the Windows installer. I had to manually add the SQL login created by the installer to the users on the DB it created, after which “Can connect to database” changed from No to Yes. I tried messing with cDBHOSTNAME to no effect. I don’t believe I’ve made any other manual changes.

Thanks,
David


#4

OK, sorry about that.

Make sure the user you created/adjusted is the owner of the database and that he has all privs.

What version of SQL Server is it? Did you have the SQL client tools installed on the web server before running the installer? Where the tools for the same version as the DB you’re connecting to?


#5

Ian,

Thanks for the reply.

The user is the DB owner. I don’t see any SQL security failure audits.

This is MSSQL 2005 (9.0.3042). The client tools were/are installed, and are the 2005 version.

Is there any logging by installer.php that I can look at?

Thanks!


#6

There’s no logging at that point in the process. Is this a Windows 2003 server? It could be a problem if you’re not on 2003.

Have you looked through this yet: http://www.userscape.com/helpdesk/index.php?pg=kb.page&id=13


#7

Yes, this is Server 2003 and yes, I’ve tried everything in that KB article.

David


#8

David,

I thought I’d chime in briefly because I had a heck of a time getting connected to SQL 2005 myself. I am actually using an odd setup in that my web server is actualy apache on a CentOS box and I’m using SQL 2005 as the back-end so I didn’t have to fiddle with the ntwdblib.dll file.

The only thing I am doing differently in my config.php file is that I didn’t specify the SQL port number. As soon as I changed my config to not list the port I was suddenly able to connect successfully.

So:

define(‘cDBHOSTNAME’,‘MY_DATABASE’);

instead of

define(‘cDBHOSTNAME’,‘MY_DATABASE,1433’);

Good luck!

-Brian


#9

Brian’s idea sounds good David. You may also want to check what port you’re using, if it’s not the standard 1433 that could also be the issue.


#10

Well, with the help of Wireshark I finally tracked it down. Apparently MSSQL was set to log only authentication failures, and helpspot_user was authenticating fine but getting a denied response to CREATETABLE, despite the fact that it was the dbowner.

I’m not sure what the problem was; it seemed to be related to a user ‘helpspot’ that I gave to the installer (which it used to create user ‘helpspot_user’). I deleted the DB, deleted both users, recreated the DB & a user, after which everything worked.

Thanks for your help, and sorry for what turned out to be something of a wild goose chase!

David


#11

Heh. I never cease to be amazed by the weird ways in which things break!!

Thanks for the update, let us know if there’s anything else you need.