HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

Custom Where upon X-Original-to: doesn't work


Hi Ian,

my custom where clause won’t work.

What i like to do is:
We receive Email by a “catch all” to one Mailbox.
Now i like to Forward Emails the Original Email to a staff in House which is no Helpspot User (Helpdesk Staff Agent)
I tried out these clause:
xRequest IN (SELECT xRequestHistory FROM HS_Request_History LIKE CONVERT( _utf8 '%X-Original-to:'
USING latin1 ) COLLATE latin1_swedish_ci)

in PhPMyAdmin it works. I’ve read that i (maybe) have to escape some Characters. But, it doesn’t work.

What is wrong?

Thanks for Help.


I don’t see a where in your subselect. should be tEmailHeaders LIKE … I believe.


xRequest IN (SELECT xRequestHistory FROM HS_Request_History where tEmailHeaders LIKE ‘%X-Original-to:’)
even doesn’t work … i know i haf wher temailheaders like in before …maybe a cut&pastze problem.

How would you solve my Issue ?



Can you use a mail rule instead of an automation rule? Mail rules have an option for headers “contains” which may be an easier way to do this if you want to instantly have them filtered off.


i’ve tried this out.
but what i like to do is:

If Headers contains “X-Origin-To:” then forward original email to external Memebr who is not a Helpspot Staff!

With Mail Rules i can’t do this.
Maybe i can create a cutom Field, feed it by Mail-Rule with explicit Characters, and create an automation Rule which is looking for this explicit Characters.

But i need then 2 Rules for one thing … not so fine!

Maybe in next Release :wink:



You should be able to do it with the custom where. I see another problem with your custom where, it shouldn’t be “SELECT xRequestHistory” it should be “SELECT xRequest”