HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

DB errors with upgrade


#1

I am getting the two following errors after the upgrade. Please let me know how I can fix this in my system.

Thanks

Database Table ‘helpspot_db.hs_request_pushed’ doesn’t exist api.requests.lib.php 1913

Unknown column ‘tSignature_HTML’ in ‘field list’ admin.users.php 100


#2

Hi I’m getting these same errors…


#3

…and we are also getting…

Unknown column ‘tAutoResponse_HTML’ in ‘field list’


#4

It looks like your databases did not update correctly. Does the HelpSpot user have permissions to create tables and columns? Ruell in your database do you see a table called hs_request_pushed? Ruell I remember you were on MySQL correct? In your config.php file is your database set to mysqli or just mysql, it should be just mysql.

Jukka, same thing and do you also see a column in HS_Mailboxes called tAutoResponse_HTML?


#5

Hi Ian,

Yes, we are on the MySQL, and can’t see any of these tables / columns. Maybe need to create those by hand. What are the types & lenghts…


#6

Well, before we do that check your config.php file and if you’re set for mysqli change it to mysql. Either way try running the isntaller.php again and going through the upgrade to see if the script can create the fields. There are other inserts that need to be done so the script really needs to create the fields.

Other things to check that may be a problem is if your MySQL client version is older than the MySQL server version. If thats the case you should upgrade the MySQL client and then try again.


#7

Hi,

Have now tried installer.php several times, and still database does not upgrade… In config.php it is mysql, and "Client API version is “5.0.45”. Current bad problem is that all the customers receive empty email autoresponds, since by default systems sends HTML emails, and we do not have nothing in datadase for those…


#8

It sounds like you may be having a problem with strict mode. Try the directions in the link below and see if that fixes it.

http://www.userscape.com/helpdesk/index.php?pg=kb.page&id=166


#9

Hi,

Now it works… :slight_smile: I did change MySQL settings, did run installer.php once again and now we are able to edit HTML emails…


#10

Excellent!!

Ruell, you’re probably having the same issue. Make that change and you should be all set.