HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

Disabling SPAM detection?


#1

Is it possible to turn off the SPAM feature? We have an internal-only web server and very little chance of SPAM happening. Right now, about 40% of the submissions from real people on the web page are being marked as SPAM, which we then have to un-mark.

Or, will it just take time for it to learn to stop? :slight_smile:

Thanks!


#2

Hmm. It sounds like your filter may have been incorrectly trained at some point. Did you ever use the spam filter to just delete portal requests? If so it’s probably been trained incorrectly.

So this is only on the web form and not emails right? First in Admin->Settings->System Security make sure the link counter is set to a high value. Second turn off the “Form Time/IP Validation”. See if that helps.

If not delete all rows out of
HS_Portal_Bayesian_Corpus
HS_Portal_Bayesian_MsgCounts

This will reset the portal spam filter. If things had been trained wrongly then this should fix that. If all else failes you could use a database script to set the value you HS_Portal_Bayesian_MsgCounts.iMsgCount to 0 in both rows. If there’s less than 40 combined messages counted the filter won’t run because there’s not enough training so keeping it less than 40 will turn the filter off.


#3

Cool. I have set the link count to 100, Automatically delete was already at 0, and I have turned off Form Time/IP Validation.

Let’s see what positive effect that may have.

Part of what may be playing into the high spam count is that the form is submitted from a different server than HS runs on. Remember that issue with us running ASP and how to wrap PHP inside so it looks pretty and all? I just rebuilt the form on our primary webserver, and it POSTS to HS from there.

Thanks!


#4

Ah yes that may be it. The new spam features check how old the form is (with that option enabled) and your external form actually can’t have the proper hash hidden field. Turning that off will probably fix this.