HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

Error during installation


#1

Hi,

Trying to install HelpSpot on Centos7 with PHP 7.2.13 installed.

All pre installation requirements check OK.

After clicking on Step 3 to finalize the installation we get an error message saying “Whoops, looks like something went wrong”.

Further investigation into Apache, and I the error log says:

[Mon Jan 07 11:39:21.290142 2019] [php7:error] [pid 14998] [client 192.168.1.114:60927] PHP Fatal error: Uncaught Error: Wrong parameters for Exception([string $message [, long $code [, Throwable $previous = NULL]]]) in /var/www/support.retailquip.com/helpspot/HS/Vendor/Illuminate/Exception/Handler.php:47\nStack trace:\n#0 /var/www/support.retailquip.com/helpspot/HS/Vendor/Illuminate/Exception/Handler.php(47): Exception->__construct(‘SQLSTATE[HY000]…’, ‘HY000’)\n#1 /var/www/support.retailquip.com/vendor/laravel/framework/src/Illuminate/Exception/Handler.php(171): HS\Vendor\Illuminate\Exception\Handler->handleException(Object(Illuminate\Database\QueryException))\n#2 [internal function]: Illuminate\Exception\Handler->handleUncaughtException(Object(Illuminate\Database\QueryException))\n#3 {main}\n thrown in /var/www/support.retailquip.com/helpspot/HS/Vendor/Illuminate/Exception/Handler.php on line 47, referer: http://support.retailquip.com:8085/installer.php?lang=english-us&step=3

Does anybody know what this error means, and what is wrong?

Everything passes installation checks so I don’t understand what’s not working.


#2

Hello!
I believe the real error is the one above it regarding cHD_LANG.

That should be set to “english-us” by default. You can manually set that in the database’s HS_Settings table where sSetting = ‘cHD_LANG’ (tValue should = ‘english-us’)

However if that’s during the installation, then I’m wondering if something else is going on there - did you make sure to select a language during the installation steps?

You may want to attempt an installation using the CLI as documented here: https://support.helpspot.com/index.php?pg=kb.page&id=468


#3

I’ve got this exact same error. The only difference is I’m installing on Windows 2016 under IIS. I’ve never gotten past the installer. I can confirm “english-us” is set as I have no other options available.