HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

Error installing on my server - ionCube Encoder


#1

Trying to run installer.php gives me this error every time. I’ve re-uploaded and tried different things but always the same result:

Fatal error:
The file …/installer.php was encoded with the PHP 5.4 ionCube Encoder and requires PHP 5.4 to be installed. in Unknown on line 0

I’m running cPanel - don’t think I have root or shell access. My PHP version is 5.4.40-something. Kind of stuck at this point, but would love to test this out and see how it works. I was hoping to just upload the files via FTP like I’ve done with all my other projects and scripts.

Any suggestions? Or am I out of luck being stuck on a limited cPanel?

Thanks!


#2

Hi,

Although my experience with cPanel is near to 0 i did have the same error when i install helpspot ionCube is a php plugin which needs to be installed into your php setup.

this plugin is included with helpspot, if you’re able to edit the php.ini of your cPanel and you add the extension to the path inside the extensions folder of the helpspot “helpspot root folder\ioncube” (also read the README in that folder on how to add the extension) you might be able to get helots running in your cPanel

Kind regards,

Edo