HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

Error_log spoofed with PHP Warning "continue" equivalent to "break"

Since upgrading to Helpspot 5, our apache2 error_log is spoofed with PHP warnings:

PHP Warning: “continue” targeting switch is equivalent to “break”. Did you mean to use “continue 2”? in xxxxx/helpspot/helpspot/pages/ajax_gateway.php on line 923

I can get rid of the warnings by replacing “continue” with “break” in line 923 of ajax_gateway.php, but of course the file is always restored when updating to a newer version, and the warning comes again.

It would be great if Helpspot could adapt the code to finally get rid of the warning.
I think its a php 7.3/7.4 issue.

Regards
René