HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

Graphical Issues (Internet Explorer)


#1

Hi Ian, and other HS Staff

I’ve been using HS for about 6 years, across 3 companies, and I love it. I’m starting the roll-out of a second installation of Helpspot at my current company, for the Plant & Logistics division, and have a question.

I was wondering if there is any development effort being put towards correcting the graphical glitches present in the HS Admin back-end when using Internet Explorer?

As with many companies, we mandate that Internet Explorer is the primary (usually only) browser installed on client machines. Our Sharepoint custom web parts, Nintex workflows and some of the custom CRM web apps we use don’t play nicely with non-IE browsers.

Unfortunately HS exhibits quite a few graphical glitches in IE that don’t show in FireFox or Chrome. Reporting tags have an ugly space in the middle, request details overflow boundaries, buttons randomly move on mouseover, etc

When it was only the IT department that was OK (we can break restrictions and use Chrome…) but I’ve now got about 20 non-technical users using the admin back-end in IE and I’m concerned the glitches will impact on usability.

I’m aware that cross-platform development is quite difficult, and that it’s easy for people to blame IE for not being as compliant as other browsers - but given the prevalence of IE in the workplace and HS being targetted towards businesses, I’m surprised to see these issues persisting for so long. I’ve noticed them ever since v3 (which in every respect, is fantastic) and they haven’t been corrected by 3.15. I’ve searched for similar posting in the forums here but can’t find anything.

Our clients are 95% IE9 on Windows 7, and the glitches appear the same on all machines. If neccessary, I can provide screenshots of the issues, or any further information that is requested. But I’d be happy for now to know that these glitches are on your radar, and will be addressed in an update soon?

Best Regards
Sam


#2

Awesome, glad you keep bringing us along!

On IE9 there are a few small things but you shouldn’t be seeing widespread issues. My guess is that compatibility mode is enabled. With that on the browser acts as an older IE which has many more issues plus compatibility mode in general adds other “special” issues.

So I’d take a look at that, most likely that’s the issue.


#3

Unfortunately the compatibility mode button does not appear the browser’s toolbar when viewing the HS admin area. I’ve checked, and HS is not outputting the “” tag, so I’m not sure why the compatibility mode button does not appear, but I am unable to ‘toggle’ this and see if it makes any difference.

I can fix the glitches by adding in overrides in the theme CSS file (blue.css at present), but this is a very ugly hack. Unfortunately it’s the only CSS file I can modify.

Barring any development on the graphical issues from the HS team, is there a way to get a custom CSS file included by HS in the admin area? I know we cannot modify the “hs-css-combined” files, but if I could add an additional, custom, file that would help.

(I know that has the potential to break HS’s “theming”, but it doesn’t have to be enforced. Just an optional extra for advanced users)

Regards,
Sam


#4

Here’s a couple of screenshots illustrating what I mean

Note that these are not the worst offenders - the worst part is the cosntant ‘jumping’ that buttons and text boxes do when mouse-overed. But obviously Ic annot capture this in a screenshot



#5

Any CSS in the combined file can be overridden in the admin theme css (blue.css) so that would be the safe way to do it. It should not be necessary though and there are no other reports of this when not in compatibility mode.

That it doesn’t show the button is really odd, perhaps there’s an IE setting to enable the button or some other setting that forcing it via a preference?

I just went through and checked this an on Win 7 using IE9 the only way I can get those errors you show is by turning on compatibility mode.


#6

Yes, that was the issue exactly! Thanks Johnny

For the reference of anyone else who may need it, Internet Explorer 8 & 9 will display any sites in the ‘Local Intranet’ zone in Compatibility Mode by default, and REMOVES the button to toggle this.

As it’s very common sot set up all internal sites in the Intranet Zone, I can imagine it would be a fairly common scenario for helpspot to be located in this zone (at helpdesk.company.com for example).

As Johnny points out above, you can toggle this setting on ‘Individual’ computers via ‘Settings->Compatibility Settings’ in IE8. (https://skitch.com/unnamed-byn27/g53pe/helpspot-v3-ccs-issues-02)
In IE9 this menu is hidden, so you must press ‘Alt’, then click ‘Tools’ then ‘Compatibility View Settings’.

I’ve gone down the Group Policy route instead, and set a GPO at User Configuration > Policies > Administrative Templates > Windows Components > Internet Explorer > Compatibility View > Turn on Internet Explorer Standards Mode for Local Intranet. Set this to ‘enabled’ (the whole thing is badly worded, but ‘enabled’ is definitely how you want to set it)

Thanks for your help, Johnny and Ian


#7

Awesome, thanks for the hand Johnny!