HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

HelpSpot on PHP 7?


#1

Have you tested HelpSpot 4.x on PHP7?

Is ionCube loader still required? I notice that ionCube loader for PHP7 is still in beta


#2

HelpSpot doesn’t yet support PHP 7. There’s some libraries that we need to swap out which currently use references and things that PHP 7 dropped or changed. So it will be a bit.

For now you’ll want to use PHP 5.6.

Ian


#4

Hello,

sorry to restart this topic but is there any timetable on that? I would really like to have Helpspot work on PHP 7.

Thanks


#5

We are getting very close and in the final stages of testing the PHP 7 integration. This will be supported in v4.6.0 when it’s rolled out.


#6

Thanks for your reply. It’s good to know it will be rolled out soon.

Thanks for your hard work.


#7

Just an update for everyone here. The beta with PHP7 support is now available: https://www.helpspot.com/releases/version-4-6-1-beta


#8

that’s cool.
thanks!


#9

Thanks for that.

Quick question though. I can’t seem to find where to download this beta version. Can you help me?

Thnaks


#10

If you want to get started testing or using the beta feel free to head over to https://store.helpspot.com/downloads. Once there, select your platform and select to view older and beta releases http://drop.userscape.com/BmuL/5cijTylF.


#11

I hate to resurrect the thread again. Above it says that helpspot will support php 7 in 4.6. All the documentation still is saying 5.6 (with a + in one instance). Is it safe to use php 7? I’m currently using 5.6 but plan on updating my server to ubuntu 16.04 next month which will install 7 by default and as a laravel user I’d prefer to use the latest version and 4.5 will have a php 7.0 requirement.


#12

Hey there, as long as you are on HS 4.6 you will be fine with php 7.0. The most up to date requirements should always be out here https://www.helpspot.com/requirements and 5.6+ is now the system requirement (changed from 5.4 through 5.6)