HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

iOS app - Installation cannot be reached


#1

Hi,

So, we’re now on Helpspot 4 and I thought “Great! an iOS app! Lets do this”… aaand falls.
When I try to log in, it tells our “Helpspot installation cannot be reached”… But this it can be reached. At least via HTTPS.
Is there something I need to turn on that I’ve not found? (Nothing in docs).
Or is it because I’m on iOS 9 Beta 5 and therefore it’s my own darn fault? :smile:


#2

Hello!

The most likely explanation is that the private API may be turned off in Admin > Settings > Web Service API. This needs to be enabled for the mobile apps to use the site.

However, there was a mobile app version where some “https” URLs’ didn’t work depending on the type of SSL connection the server had setup. These should be working now in the latest version, however. (That may have been Android only).

Last note: The latest version of HelpSpot is 4.0.10 - if you’re still on 4.0.5, we suggest updating!


#3

Hi Chris,

Yeah I enabled that but still no luck, just gives the same error. Quite stuck on what else to try… I know I’m doing my password correctly as I can log in via Safari.

Thanks for info on latest update. Our Helpspot installation doesnt tell me about new updates for some reason so I have to try and remember to look!


#4

This has now been solved!

The issue here for us was that our SSL certificate was not using TLS 1.2 which is required in iOS 9. In iOS8, I believe TLS 1.0 is also refused.

Just a heads up for anyone else who may bump in to this once iOS 9 is released.

You can test this by going to your Helpspot installation in iOS Safari and it should complain about the SSL Certificate (unable to verify).
[Sidenote: Don’t trust the certificate in Safari, it won’t help as Apps do not use Safari certificates and you cannot remove the trust afterwards]


#5

Ah, thanks for the update!!


#6

is ssl required to use the ios app? when trying to put in the installation url with http i keep getting the “Helpspot installation cannot be reached” even though i can login fine on safari mobile. Api’s are turned on…


#7

SSL is not required though it is recommended. We have an update coming out shortly (it’s in review) that fixes some various HTTP issues. Keep an eye out for the update as it may fix your issue based on what you’re saying here.