HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

Issue(s) with 'Live Lookup' since upgrading to 3.1.7


#1

Just wondered if anyone else was having issues with Live Lookup since upgrading to 3.1.7?

It works fine when it only returns a single result, and returns multiple results as expected, however when you click on the magnifying glass it doesn’t add the result to the ‘Request’ it just returns blank.

The livelookup.php has been working fine since ver. 2 up until now.

Any suggestions gratefully received.


#2

Hi Matthew,

Yes, this is a known issue. We’re working on a bug fix that should be available tomorrow. I’ll update this thread when it’s ready.


#3

Hi Ian,

I have the exact same problem.


#4

OK we’ve uploaded a patch that should fix it, please give it a go and let us know how you make out.

http://www.helpspot.com/helpdesk/index.php?pg=kb.page&id=434


#5

Hi Ian,

I have applied the new files and it has not resolved the problem.


#6

Hi John,

We’ve had several other customers apply the patch with success. Make sure you force refresh your browser, it may even be necessary to forcibly clear it’s cache, especially on IE.


#7

Ahhh yep cleared the browser cache - all good!


#8

Hi Ian,

Just tested and it’s working fine now, thanks!


#9

I am still having issues with the Live Lookup “magnifying glass” feature when multiple users are matched, the “Insert Customer Information” button works when only one user is found.

I have applied the patch and cleared my cache, I have also tried another browser entirely with no luck. Is anyone else still having issues after the patch?


#10

Hi Chris,

I just did a few quick tests and it seems OK. All the data fails to insert or just custom fields or some specific element?


#11

It’s on all fields, it seems to only be an issue when live lookup return multiple users, data is populated fine when only one matching user is found.


#12

Are you sure that ever worked for you? My guess is that you’re sending back information formatted differently for multiple results vs a single result in your Live Lookup script.

To be able to insert the data needs to be tagged in the same way as the single result (though you don’t need to include as much data if you choose not to).


#13

Our support department uses the live lookup feature pretty heavily, I would have fond out a long time before the upgrade if it was not working.

I am now getting feedback from a couple users that the problem is not affecting everyone on the team. On the systems that are not working I have confirmed that the browser cache had been cleared, and we tried from multiple different browsers, in some of the cases the systems have been rebooted since the patch was applied.


#14

hmm, there’s no per-user differences in that area. The logic in the script can server different things per user but it sounds like that’s not the case. As wacky as it sounds a reboot won’t necessarily clear the cache.

Have you tried Chrome specifically or Safari? The headers on that file that’s patched do specifically tell the browser to cache forever so applying a patch in that area means it can be tricky to get the browser to clear it. If it is working for some and not others I’d still be inclined to think it’s the browser cache.


#15

We did the same steps to clear the cache on systems that are working as the ones that are not. I am having issues connecting from browsers that have never logged into helpspot before. Is there a way to enable verbose/debug logging for LiveLookup?


#16

That would be a client side issue, in Chrome you could show the developer tools and in the console see if there’s a JS error.

If the computer has never been to HelpSpot before and it doesn’t work I’m not sure how it would be possible that it’s working at all for anyone as there are no differences in what’s served for that on the HelpSpot end.

You can try having the browser go directly to the javascript file: static_3.1.7/js/hs-js-combined.php and once you see it force refresh the browser (hold down shift and refresh) and see if that clears it.


#17

I am having an issue with Live Lookup regardless of how many results there are. When I click on the magnifying glass it returns me to to the request page. If I click on the Customer ID, it simply refreshes the Live Lookup search. Right now, I can find no way to use Live Lookup so I have to enter customer information manually. Help would be greatly appreciated.


#18

If there’s only one result you should see the results and not have to click anything. On multiple results if you’re not seeing details when clicking the ID it’s because your Live Lookup logic in your LL script doesn’t do a search that returns only one result when customer ID is passed to it.

You probably never noticed because you always used the magnifying glass.

The patch will fix your issue, however, we have 3.1.8 coming out momentarily so you might just want to wait.


#19

You are exactly right - we do the Live Lookup and it shows us a list of our customers, and historically we have just found them in a large list, clicked on the magnifying glass, and inserted the customer information. The patch did not work for me for some reason, but I’ll just wait for the 3.1.8 update. For now, I changed my script to look at a CSV file and return ONE result based on the client ID, and it is working under those circumstances. Thanks!


#20

Hi there,

Myself and some of my colleagues have run into this issue again.
I can confirm that we’ve cleared all offline data via windows disk cleanup as well as individually cleared offline content in each browser.
We’ve tried IE8, IE9, Firefox, Chrome, and Safari.
Java has been uninstalled and updated to the latest version.
We’ve tried a system restore on one of the machines and it has not helped either.
We’ve tried different profiles on the same machine.
OS is windows 7.
we’ve imported IE9 reg keys from another working system. no luck here either.

If anyone has any further advice please let me know.