HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

Live Lookup


#1

I’ve set up the Live Lookup in v1.5.5, if the lookup script is called directly (http/s), it works, but when called from within the helpspot app, it always claims it finds no records. I’m running HS behind an NTLM auth site with SSL. There were initially some errors in the log - XML Parser - syntax error - ajax gateway.php - line 353, but we no longer have that occuring.

Running PHP 4.4.4 w/Zend 3.2 + MySQL 4.1.8.

Have tried the test script also, does the same thing, but works when called directly.


#2

Can you try calling it via regular HTTP rather than over SSL and see if that works. Your PHP installation may not have the correct libraries to do the SSL call.


#3

We are having a similar problem callin a perl script from live lookup using either the command line or http GET methods. I put in a create file command in the script to see if the script is getting called by live lookup so I know that the script is not getting called. I can execute from the command lkine and it works fine. Any ideas?


#4

Hi Tony,

I sent an email over as well, so go through that list. I think it’s likely a permissions issue with the Perl script, but it may be one of the other things as well.


#5

Using documentation provided through your manual - and an actual copy of your live lookup php script. I have two files ‘bbw-livelookup.php’ - an exact copy of your script with only the path to the csv file modified - and a csv file containing customer information.

I turned on live lookup - using http get - and input the path to the php script (bbw-livelookup.php).
Saved my changes.

Tested using both an existing request and a new request. Message displayed is “no customers found”.

I assume this means that the php script is working - but not finding a match?

When creating the new request, I’ve entered nothing - just let the system default to ‘email’ as the contact via.

Then I entered a known customer id and tried again - same result. (with ‘customer_id’ and 'contact_via" both populated.

Added Email address - so that I now have customer_id, contact_via, and email populated. Same result - no customer found.

Any ideas?


#6

Where is it supposed to put the xml file? I don’t see one.


#7

Hi Betty,

OK, you’re part way there. The XML is never turned into a file, it’s just returned to HelpSpot. The XML file on the Live Lookup page is just a sample of what your script needs to produce if you’re writing the script yourself.

Also the CSV file must be in the exact format specified in the php file. That could be where your problem is. Generally it’s best to interact directly with your database and skip the CSV file because it eliminates the need to keep the CSV file up to date, but it does work if you have to use CSV.

It’s best to start by manually checking if the script is retrieving results from the CSV file. To do this from the browser go to the bbw-livelookup.php script in the browser and manually pass in information which is known to be in the CSV file.

bbw-livelookup.php?customer_id=CUSTOMER ID HERE

Your browser should show XML returned from the script. If it doesn’t then the script probably isn’t able to read your CSV file. Tinker with things until it’s working.

Once you get it working manually try from HelpSpot and it should work. If not you can check the error log in Admin->Tools->Error Log for any errors.