HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

Never-ending admin login + how to disable gzip output


Just trialling helpspot; install went smoothly and all was looking good, but I’ve run into two issues;

  1. I can’t click on any link within the admin panel without being redirected back to the login screen. I get the same behaviour using FF 3.5.3, IE 7.0, and GC 3.0. I’ve got caching permanently disabled on FF so I don’t think that’s the issue.

  2. The site which the helpspot install sits within alreday has gzip output enabled via an htaccess file, which causes this warning;

ob_start() [ref.outcontrol]: output handler ‘ob_gzhandler’ cannot be used twice.

I don’t want to disable gzip output on the whole of my site to get rid of this warning, but neither can find a way of disabling it just for helpspot. Is this possible?


It’s probably worth mentioning that I’m not running this trial in a live environment, but on localhost using WinXP, Apache 2.2.10, and PHP 5.2.7 :slight_smile:


Hi Mathew,

Well since you’re on XP it could be anything, we don’t test on XP and it has all kinds of issues. To fix the gzip error you could disable zlib in PHP that would do it.

The redirect could be related to the gzip issue, also check that you can insert into the db.


Hi Ian,

Thanks for your reply. I can’t see that XP would be the reason, but I thought I’d mention it out of completeness…

I can insert into the db without a problem, and have commented out the gzip line from my site’s main htaccess file - the login redirect still persists.


Make sure in config.php that the cHOST is right. Make sure you don’t have suhosin as it can sometimes interfere. When you login are rows added to the HS_Sessions2 table?


The cHOST entry is correct (the CSS styling disappears when it’s not!) and I don’t have suhosin installed. Rows are added to the HS_Sessions2 table when a new session is started (ie when the old cookie has expired or been removed) but not when the browser has been refreshed or restarted.


The cookie is set for the domain/ip you have HS setup for? Could be the cookie isn’t right so it’s not getting sent back to HS.