HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

Search problem with characters (å, ä and ö) saved by ISO 8859-1 names


#1

Hi,

Characters like å, ä or ö are being stored in database (in my case MySQL) by their ISO 8859-1 names. For example ö is stored as &ouml in my HS_KB_Pages table.
This cause a problem in text search so that you are not able to find words having these characters e.g. in your knowledge books.
I have modified the character setting of the tables but it didn’t solve the problem. Do you have any idea how to solve this issue?

Best regards,
Mattias


#2

Hi Mattias,

Changing the chracter setting may have fixed it going forward. Put in a name with those characters in a new request and see if it works. Changing the charset usually won’t change the data in there just data going forward.


#3

Hi Ian,
thanks for the reply.
Here is the changed I made:

  • changed the character set for the table HS_KB_Pages to UTF-8 Unicode
  • changed the collation of the same table to utf8_swedish_ci
  • created a new page using KBMPro admin page containing the word åäöåäöå
  • edited the english-us.php :
    • setlocale (LC_ALL, ‘sv_SE’, ‘swedish’);
    • define(‘helpspot_charset’,‘UTF-8’);
    • define(‘lg_tidycharset’,‘utf8’);
  • restarted the apache server (although it’s not necessary)
  • finally, went to the portal and searched for the word, but nothing found.

Do you think something is wrong with that?
Which steps should I follow to enable e.g. Swedish language in the user side (portal). I’m going to use the default language for the admin side.

Thanks,


#4

Actually no, that won’t work. PHP doesn’t properly support UTF8 so it’s not recommended you make those changes. You should use the proper character set for your language and not UTF8.


#5

okey, I have changed the settings back to latin1.
My issue is exactly the same as a post from last year (http://www.userscape.com/helpdesk/index.php?pg=forums.posts&id=6491). The wysiwig editor tinyMCE generates escape codes for Swedish characters. I would like to disable this conversion. I have tried the solutions mentioned in the old post but still the escaped codes are generated.
Do you know how one can solve this issue in the current version of KBMPro?
Thanks


#6

OK so the problem isn’t with the customer names it’s with the body of the requests. What is KBMPro?


#7

obs! wrong name, I meant Helpspot, not KBMpro.

Yes, customer’s name is correct, even the body of the request and notes are stored without conversion. The only problem I have is the HS_KB_Pages.tPage field which is stored as escaped codes!

What’s your idea?


#8

Ah. Well, if you know HTML one work around is to not use the wysiwyg in the KB’s. In “preferences” in the top right corner of the screen is an option for “Do not use the WYSIWYG editor in the knowledge books”

We do have this issue tracked as a bug. If not using the wysiwyg is not possible I might be able to try to put a patch in for you, probably not for a week or two though.


#9

I can live with it for now but I am going to buy HelpSpot and then the patch is really needed. Do you think the patch will be released in more or less two weeks?