HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

Segmentation fault


#1

i have installed apache php5 mysql, and all modules you require.

When i try to setup a script. I get php error

[Mon Dec 21 14:18:16 2009] [notice] child pid 3971 exit signal Segmentation fault (11)


#2

it probably has to do with zend optimizer, i have tryed zend optimizer 3.3.3 and 3.2.8 same error happends


#3

Hi Dejan,

You most likely need to upgrade to ZO 3.3.9 if you’re on Linux. It can be downloaded from our installation page: http://www.userscape.com/helpdesk/index.php?pg=kb.page&id=3


#4

I can confirm that Solaris 10 u8 x86 running PHP 5.2.11 with Zend Optimizer 3.3.0 does the same thing with HelpSpot 2.7.0

Since Zend Optimizer no longer supports Solaris (grr) I will need to replatform to either Linux, OS X, or FreeBSD.


#5

Hi Nate,

We now offer an IonCube build as well, so you may want to look into that. I believe it supports Solaris. It’s available on the download page, link is in the 2.7 email.


#6

Would that require the IonCube decoder or the PHP accelerator (or both)?


#7

It would require the IonCube decoder. The PHP accelerator is I believe a bytecode cacher and isn’t required. I’m not sure how that would affect things actually.

IoncCube can be installed along side Zend Optimizer if you want to try it out.


#8

In theory IonCube accelerator would cache the code into memory which is good for performance but causes some wonkiness with an upgrade (have to flush the cache).

I will try the IonCube decoder and report back what I find out.


#9

Solaris 10u8 x86 with PHP 5.2.11/Apache 2.2.12 works with HS 2.7.0 and ionCube


#10

We haven’t tested it with any accelerators so I wouldn’t mess with that, at least not in production. HelpSpot is used in some pretty high volume installations without them so I think generally for an app like HS they’re not necessary.

Ah, good to know it works there!