HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

Slowness since upgrading to version 4


#1

Hi,

We have been using Helpspot for many years, since upgrading to version 4 we have noticed everything appears to be running very slowly. When you click on anything you now have a wait of around 4/5 seconds before the pages load. It is running on the same server as before with the same software. The only difference is previously we were using WAMP, now we are using the built in methos that gets installed when you run the Helpspot installer.

I have take a look using the inspector in Chrome and attached a screenshot below:

Is there any settings or anything we can change to speed it up?

Thanks


#2

Hmm, generally speaking 4 is a good bit faster so something seems off.

Are you saying now you’re using our Windows installer right? What database type are you using? If MySQL is it ours or the one that came with WAMP before?

How many requests do you have in your system? Check your disk space, is everything OK there?

One thing to look at (not sure how technical you are) is version 3 uses MyISAM tables, version 4 uses InnoDB tables. It’s possible your MySQL config file is optimized for MyISAM instead of InnoDB so there’s not enough memory in the InnoDB buffers and such for the data to be accessed quickly.


#3

Hi,

We’re experiencing slowness after upgrading to version 4.0.18 as well. Is there any fix to that?

Our Helpspot has been upgraded using the wizard (IIS and Helpspot’s MySQL).

Thanks


#4

Hi Michal,

That hasn’t generally been an issue and most installations are now upgraded so I’d recommend putting in a request to support so we can take a closer look at what’s going on. https://support.helpspot.com/index.php?pg=request

Ian


#5

I found that with our system, all we needed to do was add a line in the hosts file for localhost (i.e. 127.0.0.1 LOCALHOST)

This cured the slowness for us and Helpspot is working as quick (if not quicker!) than version 3.


#6

Just got reply from Matt advising to replace define(‘cDBHOSTNAME’,‘localhost’); with define(‘cDBHOSTNAME’,‘127.0.0.1’); in the config file.

That did the trick! Thank you very much guys :slight_smile:


#7

I also had this problem. It was taking about 4 seconds to open an existing ticket then another 4 for the history to open. Then when you did a Update and Close a ticket it took about 10 seconds to get back to my inbox.

I went into E:\Program Files (x86)\helpspot\helpspot\php.ini and found the reference to cDBHOSNAME and changed it to 127.0.0.1 as suggested. Then I restarted the HelpSpotApache and HelpSpotSphinx services. Now everything is taking 2 seconds or less!

I’m not sure if I needed to restart HelpSpotSphinx. I did it as a just in case. :slight_smile:


#8

Ian,

Do you know where we’d find this in a IIS build?


#9

The primary spot to fix this is actually in config.php which is in the root HelpSpot folder on all platforms.


#10

Here’s the exactly URL on Windows (assuming you didn’t choose a custom location) C:\Program Files (x86)\helpspot\helpspot\config.php


#11

I see the setting now. This only applies to users that are using on-board Helpspot’s MySQL. Doesn’t apply to those using an external SQL server.