HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

SSPI authentication errors running against Sql 2005


#1

Hi all;

We recently moved our HelpSpot database to a Sql 2005 box (same name as our older 2000 server, but a fresh machine instead of an upgrade), and are now seeing a flood of the following errors in the event log:

SSPI handshake failed with error code 0x8009030c while establishing a connection with integrated security; the connection has been closed. [CLIENT: 10.10.20.24]

Has anybody experienced these? HelpSpot doesn’t use integrated authentication, and it continues to function normally, but every time a login attempt is made (even though it uses Sql authentication and is successful) we see one of these errors.

Any help would be appreciated.

Thanks,
Jason


#2

The link below seems to indicated it’s an IIS issue. We’ve never heard of this error before.

http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=285649&SiteID=1


#3

Thanks, Ian, I’ll keep looking. I’ve seen that link (and quite a few others) suggesting the same thing. The IIS box hasn’t changed at all, and we didn’t see the errors on the old Sql box, but I’m reasonably sure it’s related to how we renamed the server during the switch to production. I just thought I’d throw it out there, as HelpSpot IIS requests seem to be the only thing causing the issue – all other IIS apps on the same box authenticate using Sql authentication, and don’t seem to cause the errors.

Thanks for taking the time to look into it!

  • J

#4

Sorry I can’t be of more assistance. I’m not seeing it on our test boxes and have no other reports of it. It’s probably some type of odd configuration issue. There are some security settings in the php.ini for MSSQL you could take a look at those. They should all be off by default if you used the Windows Installer but you never know, maybe they’re causing an issue.