HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

Tasks.php


#1

Trying to install HelpSpot 2.4.7 on Centos 5 but when I run tasks.php I get the folowing errors:

/web/dev/cshelp/tasks.php: line 1: ?php: No such file or directory
/web/dev/cshelp/tasks.php: line 2: 4203: command not found
/web/dev/cshelp/tasks.php: line 3: syntax error near unexpected token newline' /web/dev/cshelp/tasks.php: line 3:?>’

This is the same whether I run it from crontab or command line.
Zend Optimizer is installed.

php -v returns:

PHP 5.1.6 with Suhosin-Patch 0.9.6 (cli) (built: Nov 5 2007 17:46:20)
Copyright © 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright © 1998-2006 Zend Technologies
with Zend Extension Manager v1.2.0, Copyright © 2003-2007, by Zend Technologies
with Suhosin v0.9.20, Copyright © 2002-2006, by Hardened-PHP Project
with Zend Optimizer v3.2.6, Copyright © 1998-2007, by Zend Technologies

Has anyone else seen this error?

Thanks,
Dave


#2

Hi Dave,

You need to pass it through PHP. So something like this in Cron:

/usr/bin/php -f /path/to/tasks.php


#3

Thanks,

I knew it would be something blindingly obvious…

-Dave


#4

No problem, glad that was it Dave!