HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

This access key is not on file error when ticket staff generated


#1

We are getting a “This access key is not on file” error when when you click the link to a ticket that was generated any way other than on the public form or via email. The link looks correctly formed, but neither the link in the email or the “View in Portal” link in the portal will work.


#2

Hi Jimmy,

Are you using secondary portals or no? If you are the request can only be opened in the portal it was opened from, currently the default link in the request just leads to the default portal. Perhaps that’s the issue?


#3

We are using secondary portals & we followed the steps to set up the primary as a secondary. The interesting part is that the link works for any ticket created via email or the webform, but the link/Access Key will not work for any ticket created via Create Request in the Admin. Therefore if it were a secondary portal configuration issue, I would think that no tickets would work?


#4

It depends on the configuration of things, but that sounds correct. This is something we’re going to be fixing in version 3 though so that it shows in the correct portal.


#5

So are you saying that it is a bug in version 2.7 & therefore not possiable? Or are you saying that I can adgjust my configuration & it will work?


#6

Sorry for the confusion.

The manually built ones are not associated with a portal which is why it’s not showing up and you don’t have a default one to show it in (since you have it configured as a secondary).

It’s one of those things that’s somewhere between an oddity and a bug. What we’re going to be trying to do in v3 is make requests show correctly in their portals instead of the default.

You should be able to make a change for this I just realized though. When you create a request make sure you set the “send from” to the mailbox of the portal you want it to be associated with. Note that the default is not the same even if it’s the same mailbox, you must select the mailbox from the drop down.

This will allow the request to be displayed when a customer logs in and I believe with the accesskey as well.


#7

I changed the “Send email from” from the Default to the email address that is associated with the portal & it worked. Is there a way default the default to the one for the portal?


#8

Yes, in Admin->Settings->System->Default Send From