HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

Trial of 1.5.5 fails to upgrade to 2.0


#1

I had the 1.5.5 trial up and running just fine and then tried to upgrade it to version 2.0 When the installer.php file tried to run I accepted the EULA. On the next screen however, I got a message that it could not connect to the database.

I am using the windows installer (for both 1.5.5 and 2.0), with IIS for the Web Server and MySQL for the database. It connected to the database just fine when using the 1.5.5 version. The install documentation I found said that if I was using the windows installer, to just run it and follow the prompts. It seems that there must be a little more to it than that.

Since the system was just a trial. I even uninstalled the 1.5.5 version and tried a fresh install using 2.0 and had the exact same results. The system fails to connect to the MYSQL database. The config.php file shows the correct server name for the database as well as the original database user and password.

What have I overlooked?


#2

Hi Steven,

Are you running Windows server 2003? Check to see if the MySQL process is started, perhaps it couldn’t restart for some reason. It’s named HelpSpotMySQL.


#3

It is Win2k3. Meant to meantion that. I’ll check for that process first thing in the morning.


#4

The HelpSpotMySQL Service wasn’t started. I was able to start it manually and the upgrade proceeded. Thanks.


#5

Excellent! Let me know if you have any other trouble.