HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

Website issue after upgrade to v4.5.7


#1

Hi!

I recently updated Helpspot from 4.0.30 to 4.5.7 for a customer.

After installation process quits, the routine wants to open the url, but the browser now says
"This page can’t be displayed" (IE) or
"The page isn’t redirecting properly
Firefox has detected that the server is redirecting the request for this address in a way that will never complete." (Firefox)

I found an install-logfile now in C:\Program Files (x86)\helpspot\logs
The following issues are registered:


Executing C:\Windows\system32\iisreset.exe /enable
Script exit code: 2
Script output: The system cannot find the file specified.
Script stderr: Program ended with an error exit code
Error running C:\Windows\system32\iisreset.exe /enable: Program ended with an error exit code

Later…

Executing C:\Program Files (x86)\helpspot/reconfigure_iis.bat
Script exit code: 183
Script output: Unlocked section “system.webServer/security/isapiCgiRestriction” at configuration path “MACHINE/WEBROOT/APPHOST”.
Unlocked section “system.webServer/handlers” at configuration path “MACHINE/WEBROOT/APPHOST”.
Unlocked section “system.webServer/defaultDocument” at configuration path “MACHINE/WEBROOT/APPHOST”.
Unlocked section “system.webServer/fastCgi” at configuration path “MACHINE/WEBROOT/APPHOST”.
ERROR ( message:Cannot find requested collection element. )
Applied configuration changes to section “system.webServer/handlers” for “MACHINE/WEBROOT/APPHOST/Default Web Site/helpspot” at configuration commit path "MACHINE/WEBROOT/APPHOST/Default Web Site/helpspot"
ERROR ( message:New add object missing required attributes. Cannot add duplicate collection entry of type ‘add’ with unique key attribute ‘path’ set to ‘C:\Program Files (x86)\helpspot\php\php-cgi.exe’

. )
Applied configuration changes to section “system.webServer/defaultDocument” for “MACHINE/WEBROOT/APPHOST/Default Web Site/helpspot” at configuration commit path "MACHINE/WEBROOT/APPHOST/Default Web Site/helpspot"
ERROR ( message:New application object missing required attributes. Cannot add duplicate collection entry of type ‘application’ with combined key attributes ‘fullPath, arguments’ respectively set to 'C:\Program Files (x86)\helpspot\php\php-cgi.exe, ’

. )

Script stderr:
Program ended with an error exit code
Error running C:\Program Files (x86)\helpspot/reconfigure_iis.bat : Program ended with an error exit code

The log quits with:
Installation completed
Log finished 07/24/2016 at 11:17:35
Launching http://helpdesk.hatteland-display.com:80/helpspot/admin.php

After that, I both tried an IIS-reset and flushdns, without getting the issue solved.
As I am not an expert in webservices, I don’t know how to continue now. Any help would be highly appreciated.

Best regards,
Karsten


#2

Hi Karsten,
It looks from that error like you may have two references to C:\Program Files (x86)\helpspot\php\php-cgi.exe in your web.config file of your helpspot install. This file controls the loading of php and can only have one instance of the php-cgi instantiated. I believe the web.config file should be located in C:\Program Files (x86)\helpspot\helpspot\web.config. Feel free to email you web.config file into support as well if eliminating a second reference to php-cgi.exe doesn’t work.
Thanks,
Matt


#3

Thanks for fast response, Matt.I’ll check this out and give a feedback soon.


#4

Hi Karsten,

I have had similar kind of problem you faced. Access denied when launching Helpspot in browser. I believe by now you have resolved your issue. Would you be kind enough to share your solution? Thanks in advance.

bh goh


#5

Of course I can. Sorry that I did not reply after my issue was solved.

In my installation, it was not exactly the solution that Matt posted, but nevertheless it was regarded to the web.config-file in the %Program Files%\helpspot\helpspot folder.
I compared the content of the file before and after installation. After installation the following line was missing:

<httpRedirect enabled="false" />


See the whole content of the file and the correct placement of this line from my installation here:

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
    <system.webServer>
        <handlers>
            <add name="PHP_fastcgi" path="*.php" verb="GET,HEAD,POST" modules="FastCgiModule" scriptProcessor="C:\Program Files (x86)\helpspot\php\php-cgi.exe" resourceType="Either" requireAccess="Script" />
        </handlers>
        <defaultDocument>
            <files>
                <add value="index.php" />
            </files>
        </defaultDocument>
    <httpRedirect enabled="false" />
    </system.webServer>
</configuration>

Hope this helps! :slight_smile:


#6

Thank you Karsten for sharing your solution.

I got mine resolved by replacing the httpd.conf file from the backup copy.