HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

Whoops, looks like something went wrong


#1

Trying to install the self hosted version on a HostGator account, I get this “Whoops, looks like something went wrong.” After submitting the license screen.

If I add in define(‘cDEBUG’, true); to debug I ge the following.

SQLSTATE[HY000]: General error: 1214 The used table type doesn’t support FULLTEXT indexes (SQL: ALTER TABLE HS_Forums_Posts ADD FULLTEXT INDEX ft_forum_post (tPost))

Any help or points in the right direction is greatly appreciated.

-Rich


#2

hello sir, i had the same issue but the problem is that the public_html or www folder is not relating to .env file in laravel so all you have to do is

  • go to the right to corner button for settings
  • configure hidden folder to be visible
    -then u will notice that your .env file is not in the same path with your laravel folder.
    -place it appropriately then it will definately work.
    i have been debugging for 16 hours for the issue and that is exactly what i did to get mine to work just now. i hope it does the same for you.

Please rate if it works for anyone
Happy to be here its my first time


#3

I don’t think the suggestion from Schneider is quite right in this case. You database currenlty doesn’t support fulltext indexing. This is most likely because you are on an older version of MySQL. HelpSpot utilizes InnoDB storage engine which added fulltext support in MySQL 5.6. Make sure you are updated to at least that version.