HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

Whoops something went wrong

I have a recent helpspot windows install(apache web server) that was working without issue. Last night a storm came through our region and knocked out power, and on reboot the site does not come back online.

The only message I see is:

Whoops, looks like something went wrong.

Any ideas?

Debug error indicates incorrect credentials, but I never changed any of the user information.

HelpSpot could not connect to the database, likely due to incorrect credentials supplied in config.php. The error received from the database was: SQLSTATE[HY000] [2002] No connection could be made because the target machine actively refused it. #0 [internal function]: {closure}(Object(Illuminate\Database\DatabaseManager), Object(HS\HelpSpot)) #1 C:\Program Files (x86)\helpspot\helpspot\vendor\laravel\framework\src\Illuminate\Container\Container.php(698): call_user_func(Object(Closure), Object(Illuminate\Database\DatabaseManager), Object(HS\HelpSpot)) #2 C:\Program Files (x86)\helpspot\helpspot\vendor\laravel\framework\src\Illuminate\Container\Container.php(682): Illuminate\Container\Container->fireCallbackArray(Object(Illuminate\Database\DatabaseManager), Array) #3 C:\Program Files (x86)\helpspot\helpspot\vendor\laravel\framework\src\Illuminate\Container\Container.php(443): Illuminate\Container\Container->fireResolvingCallbacks(‘db’, Object(Illuminate\Database\DatabaseManager)) #4 C:\Program Files (x86)\helpspot\helpspot\vendor\laravel\framework\src\Illuminate\Foundation\Application.php(462): Illuminate\Container\Container->make(‘db’, Array) #5 C:\Program Files (x86)\helpspot\helpspot\vendor\laravel\framework\src\Illuminate\Container\Container.php(806): Illuminate\Foundation\Application->make(‘db’) #6 C:\Program Files (x86)\helpspot\helpspot\vendor\laravel\framework\src\Illuminate\Database\DatabaseServiceProvider.php(16): Illuminate\Container\Container->offsetGet(‘db’) #7 C:\Program Files (x86)\helpspot\helpspot\vendor\laravel\framework\src\Illuminate\Foundation\Application.php(585): Illuminate\Database\DatabaseServiceProvider->boot() #8 [internal function]: Illuminate\Foundation\Application->Illuminate\Foundation{closure}(Object(Illuminate\Database\DatabaseServiceProvider), 8) #9 C:\Program Files (x86)\helpspot\helpspot\vendor\laravel\framework\src\Illuminate\Foundation\Application.php(585): array_walk(Array, Object(Closure)) #10 C:\Program Files (x86)\helpspot\helpspot\bootstrap\helpspot.php(86): Illuminate\Foundation\Application->boot() #11 C:\Program Files (x86)\helpspot\helpspot\helpspot\lib\util.lib.php(11): unknown() #12 C:\Program Files (x86)\helpspot\helpspot\helpspot\portal\logic.php(32): unknown() #13 C:\Program Files (x86)\helpspot\helpspot\index.php(19): unknown() #14 {main}

Config and sphinx files match for user credentials

Hello!

Apologies, we didn’t respond here - did you resolve this?

The error SQLSTATE[HY000] [2002] No connection could be made because the target machine actively refused it. is the important one here.

My best guess is that the database is simply not running OR no longer listening on a network (SqlServeR).

If you’re using MySQL, ensure MySQL is still running in the Services panel (the service will be called mysql or helpspotmysql).

If you’re on SqlServer, then ensure it’s both running and the network settings for SqlServer are enabled so it listens for connections over the network.