HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

You don't have permission to access /admin.php on this server


#1

Hi there,

I’ve just installed HelpSpot for the first time (self-hosted, version 4.6.4).

It seemed to install okay, but I’ve just noticed that whenever I click the Save button on the Admin > Settings pages (/admin.php?pg=admin.settings), I get a 403 error message:

Forbidden
You don’t have permission to access /admin.php on this server.
Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

Any ideas why this is happening? There’s nothing in the error_log file. I’ve enabled errors in config.php but there’s nothing appearing in data/logs at all.

I can save settings fine on the staff page okay (/admin.php?pg=admin.users&resourceid=1&showdeleted=0).

My hosting is cPanel reseller hosting using PHP 7 (PHP Server Variables (php:7.0.13 , zend:3.0.0) | Encoded With: ionCube), The same issue happens if I change the PHP to PHP 5.6.

Thanks,

Stephen


#2

Hey Stephen

That’s a new one for us, however it might be related to permissions with the cpanel hosting. Do you have your settings set to save attachments to the disk drive? (That’s a default setting, so you likely do).

HelpSpot tries to write a test file to the attachment save location when settings are updated to ensure it can write to it during normal operation (when emails with attachments come in, or attachments are added in responses within the admin side of HelpSpot). Potentially that’s causing that error (although HelpSpot is designed to catch the error there, perhaps something else is cropping up with how the server is configured).

Have you made the “data” directory writable? Depending on how cpanel is setup, you may need to make the data directory world-writable (chmod -R 0777 data).


#3

Hi Chris,

Thanks for your reply.

Yes, the setting is set to save attachments to the disk drive. I’ve just changed the folder permissions for /data/documents from 755 to 777, but that didn’t help and I’m still getting that error when I save the settings: https://www.dropbox.com/s/imfapjrpgiammqv/Screenshot%202016-12-30%2017.13.43.png?dl=0

The data directory was 755, but I’ve just changed that to 777 too, but that didn’t help either I’m afraid, and there’s no logs or anything in that folder either.

Do you have any other ideas at all? I’ll also open a ticket with the web host in case it’s something they have any idea about.

Thanks,

Stephen


#4

Hi Chris,

This issue is now fixed! It turned out that it was a web hosting issue. Here’s what they said:

It was running up against one of our security rules, which seemed to think it was SQL injection - a false positive, so I’ve disabled the rule in question for this site (but left all other rules active).

Thanks,

Stephen


#5

Ah ha! Good to hear, thanks for letting us know.