HelpSpot Help Desk Software | HelpSpot Blog | HelpSpot Support

Zend Optimizer not installed


#1

I promise I installed it, but I still get this error when I try to run the installer.php Am I missing something…

Fedora Core 5
Stock Install + Developemnt Tools
Apache Webserver (Default Config)
MySQL Server (Default Config + Created Helpspot DB)
Installed Zend with default settings

test.php says Im Powered by Zend Engine 2

Please help…


#2

I Found it Myself. Here is what I did…

I guess there is some issues with version 3.x.x of the Zend Engine and PHP 5.1.x

I rolled back to Zend 2.6.2 and all seems to be working fine now. Hope this helps people.

ta ta.


#3

Thanks Troy! Yep the Zend 3.x series is still a bit new. We recommend the 2.6.2 version until they work all the bugs out of 3.x.


#4

I tried this too but it did not work. I am running 2.6.2 with MySQL 5.0.27 and PHP version 5.2.0 and I am still getting the the message that I do not have Zend installed. All this on a Windows 2003 server running IIS 6.0.


#5

Hi Ian,

PHP 5.2.0 just came out 2-3 days ago. The Zend Optimizer has not yet been updated for it. You should use an older version, something in the 5.1.x branch and it will work fine. We’ll be posting the new Zend files as soon as Zend releases the updates.

Ian


#6

I went to PHP’s site and they dont offer a 5.1.x version for download, could you reccomend a site?


#7

Nevermind, I found a copy of 5.1.4.


#8

OK, great. I talked with Zend it looks like they won’t have an optimizer ready for 5.2 for 6 weeks or so. I’m going to add a note to our requirements page that 5.2 doesn’t currently work.